Urban Developer System Requirements

The Software may only be installed and used on personal computer equipment, including a server or individual computer, which meets or exceeds the following minimum system requirements:

Prerequisite software (Mandatory)

You can only have one version of Urban Developer running at a time. The soft lock key version can only be run locally and cannot be installed on a server or accessed remotely.

Local administrator rights may be required for installation and use of the software.